If this is your first visit, be sure to check out the Forum Rules. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.
Welcome to RPGamer's new forums running under Vanilla Forums! If you're run into any odd or strange issues after our software migration please see this thread for details

New Site Feedback Thread

Alex FullerAlex Fuller Managing EditorRPGamer Staff
edited April 28 in Site & Forum Support
Hi all,

Please place any feedback or issues with the forums here. We can't promise that we'll act on any suggestions but we will consider them.

Thanks!

Related Post
"Time is an illusion. Lunchtime doubly so."
Twitter: severinmira | Xbox Live: Severin Mira | PSN: severinmira (EU) | NNID: severinmira
Final Fantasy XIV: Sevvi Taubemira (Leviathan)

Comments

  • TheDoomhammerTheDoomhammer Prod with the Prod Full Members
    I dunno if there's anything you guys could do to 'fix' this, but just advising that the confirmation email for signing up to the new site got sent straight into my spam folder, so If anybody else thinks they're not getting it make sure to check there!
  • Charalampos PapadimitriouCharalampos Papadimitriou Administrators, RPGamer Staff
    Thanks for the feedback. We're aware of the email issue, and it's because we haven't set up a proper smtp server, and are instead using PHP mail function which, to keep it short, basically spoofs email-related stuff, which trigger spam filters. One of these days we'll set up something more legitimate :)
  • slimehunterslimehunter Full Members
    The new site looks good, but the google search link is not working, possibly due to the https prefix.
  • Charalampos PapadimitriouCharalampos Papadimitriou Administrators, RPGamer Staff
    The new site looks good, but the google search link is not working, possibly due to the https prefix.

    Do you mean the site search? I wasn't aware we had a google search :D

    I'm having trouble reproducing the issue though if that's what you mean. I wonder what's different.
  • Charalampos PapadimitriouCharalampos Papadimitriou Administrators, RPGamer Staff
    Oh you mean the link directly from google. Thanks! Works for admins apparently but not for non admins. Will look into it
  • slimehunterslimehunter Full Members
    Oh you mean the link directly from google. Thanks! Works for admins apparently but not for non admins. Will look into it
    Yes, sorry. That's what I meant. Both linking to RPGamer directly from Google, and typing in the link (with https instead of just http) looks like it's resulting in the same issue. Thank you!
  • Charalampos PapadimitriouCharalampos Papadimitriou Administrators, RPGamer Staff
    Yeah we haven't yet set up SSL, we're working on it, but currently our DevOps team is asleep :D .
  • maryadaviesmaryadavies She Shoots For The Stars Somewhere east of Atlanta, GAModerators
    edited May 3
    Okay, I found a bug ><

    I recently cleaned my cache and stuff (/swat Windows 10 April Creator's Update! It killed my antivirus, so I had to swap). Came directly to the forums, tried to log back in and it wouldn't let me. (I got a oops! crash notice) I had to go to the site and go to the forums from there to get it to let me log in.

    Since I already linked n'stuff, could you fix that?
    93a24222217c9c20a686db8be4676a84.jpg
    My personal page
    New to the boards? Confused? Find the answers here.
  • Charalampos PapadimitriouCharalampos Papadimitriou Administrators, RPGamer Staff
    I tried reproducing this issue but I'm not able to.

    I used an incognito tab to visit the forums, so I was not signed in. I clicked Sign In, and it took me to the website to log in. I logged in there, and it took me to the forums, now logged in.

    Can you provide a set of steps that reproduces the issue?
  • maryadaviesmaryadavies She Shoots For The Stars Somewhere east of Atlanta, GAModerators
    edited May 3
    Okay, let me spell out what happened.

    1. Browser (I use Firefox) started really misbehaving due to antivirus getting messed up by the Win 10 April Creator's Update (but I didn't know that at first; turned out uninstalling Avira fixed it. I changed it for Avast!) As I always do first thing when it misbehaves, I used CCleaner (free version) to clear cookies and cache, everything, thereby totally logging me out from both site AND forums.
    2. Tried to log back in from the forums. Managed to log in on the site but it errored on the forums.
    3. Got mad, went from site to forums, and THEN managed to login the forums without the error.

    That help? That's basically what I did. Try logging yourself out from BOTH and see what happens. Make sure you visit the forums first after that.

    P. S. If you're still having trouble seeing this error, I'll be hanging in #rpgamer all day as Elizara, poke me. ^^
    93a24222217c9c20a686db8be4676a84.jpg
    My personal page
    New to the boards? Confused? Find the answers here.
  • Charalampos PapadimitriouCharalampos Papadimitriou Administrators, RPGamer Staff
    edited May 3
    I'll try to reproduce it again later on a clean machine. If you can reproduce it again on your end that would be helpful. I'm trying to see if this is due to the site, or just the forums themselves. Sometimes the forum can get overloaded and error out, which is unrelated to the site update, and all the site update does is just pass on login credentials to the forum, so I can't see how it would be breaking things. Mostly it should just refuse to log you in if the credentials aren't sent.

    Will keep looking into it though, thanks for reporting!
  • maryadaviesmaryadavies She Shoots For The Stars Somewhere east of Atlanta, GAModerators
    edited May 3
    Kk. I'll try to do the CCleaner thing again later on. Oh and one more thing that might of made a difference; I run both Ublock Origin and Noscript; I don't think Noscript is causing any problems (I allowed the site and everything..). Yes, I'm aware that Ublock Origin can do both but the interface for allowing stuff gives me a headache; I've never been able to get it to let me allow stuff. :-q So for me it's basically a adblocker. Noscript, now that the author has beaten it into shape, is more intuitive for me.
    93a24222217c9c20a686db8be4676a84.jpg
    My personal page
    New to the boards? Confused? Find the answers here.
  • PsychotronPsychotron Member Full Members
    Really disappointed with the new site. I can't see reviews grouped by system anymore. I'm not a hardcore gamer, but I used to come here to get my quick information about a new RPG. Having to investigate the site for the latest reviews isn't going to work for me. Now I have to click on each recently released game to see if it has a review. It doesn't even look like I can search for games now, which is the only reason I can think of for a redesign. I also lost access to my account and had to reregister for the forums (now for some reason all my old data appears). It's been awhile since this redesign, and I really wish I knew the reason for the redesign. It's so much harder to use now and it just looks cheap and messy, like a generic WordPress site. The old site looked a lot neater, snazzier, and unique. I don't have tons of friends around to talk about RPGs. So if I can't have a quick way to see all the reviews, I have no idea if a game is good or not. Plus, how are people supposed to come back to these forums if they think their account is gone. I don't talk on the forums much, but I do have newbie questions or opinions every once in a while.
  • Charalampos PapadimitriouCharalampos Papadimitriou Administrators, RPGamer Staff
    edited September 26
    Psychotron wrote: »
    Really disappointed with the new site. I can't see reviews grouped by system anymore. I'm not a hardcore gamer, but I used to come here to get my quick information about a new RPG. Having to investigate the site for the latest reviews isn't going to work for me. Now I have to click on each recently released game to see if it has a review. It doesn't even look like I can search for games now, which is the only reason I can think of for a redesign. I also lost access to my account and had to reregister for the forums (now for some reason all my old data appears). It's been awhile since this redesign, and I really wish I knew the reason for the redesign. It's so much harder to use now and it just looks cheap and messy, like a generic WordPress site. The old site looked a lot neater, snazzier, and unique. I don't have tons of friends around to talk about RPGs. So if I can't have a quick way to see all the reviews, I have no idea if a game is good or not. Plus, how are people supposed to come back to these forums if they think their account is gone. I don't talk on the forums much, but I do have newbie questions or opinions every once in a while.

    Or you can just go here:

    https://rpgamer.com/review/

    As for the rest, it's less of a redesign and more of a functionality update. Putting content on the old site was a massive pain because it was literally created with 1990s tech.

    As a bonus, you do get an awesome new look, and the ability to browse the site on your phone in a way that doesn't make you want to gouge your eyes out.
Sign In or Register to comment.